About the dashboard

The dashboard tells you at a glance whether the ABR is functioning normally or is experiencing problems. This data is sourced directly from internal monitoring systems.

ABR - Degraded performance
Incident Report for Australian Business Register
Resolved
This incident has been resolved.
Posted Jun 23, 2021 - 16:40 AEST
Investigating
We are currently investigating this issue.
Posted Jun 23, 2021 - 12:45 AEST
This incident affected: ABR Web Services (Identifier Search) and ABN System (Apply for an ABN, Update your ABN).