About the dashboard

The dashboard tells you at a glance whether the ABR is functioning normally or is experiencing problems. This data is sourced directly from internal monitoring systems.

ABR system outage

Incident Report for Australian Business Register

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 16:39 AEST

Investigating

We are aware there are issues with the Australian Business Register (ABR) and it's currently under investigation.
Posted Jul 29, 2025 - 16:38 AEST